Simple Authentication and Security Layer: Difference between revisions

From Wikipedia, the free encyclopedia
Jump to navigation Jump to search
imported>Citation bot
Added date. | Use this bot. Report bugs. | Suggested by Abductive | Category:Computer access control protocols | #UCB_Category 21/38
 
imported>SirOlgen
m →SASL mechanisms: LINT stripped tag fix - removed links to deleted sections of MSN Chat article per the User:Cewbot update that left a stripped <dt> tag
 
Line 33: Line 33:
   |title=A GSS-API Mechanism for the Extensible Authentication Protocol
   |title=A GSS-API Mechanism for the Extensible Authentication Protocol
   |author=Sam Hartman
   |author=Sam Hartman
|date=December 2013
  |date=December 2013
}}</ref>}}
}}</ref>}}
{{term|[[MSN Chat#GateKeeper and GateKeeperPassport|GateKeeper]] (& [[MSN Chat#GateKeeper and GateKeeperPassport|GateKeeperPassport]])}} {{defn|a challenge-response mechanism developed by [[Microsoft]] for [[MSN Chat]]}}
{{term|MSN Chat GateKeeper (& GateKeeperPassport)}} {{defn|a challenge-response mechanism developed by [[Microsoft]] for [[MSN Chat]]}}
{{term|[[OAuth#OAuth 2.0|OAUTHBEARER]]}} {{defn|[[OAuth#OAuth 2.0|OAuth 2.0]] bearer tokens (RFC 6750), communicated through TLS<ref name=rfc7628>{{cite IETF |title= A Set of Simple Authentication and Security Layer (SASL) Mechanisms for OAuth |rfc= 7628 |date=August 2015 |publisher= [[Internet Engineering Task Force|IETF]] |accessdate= October 7, 2016}}</ref>}}
{{term|[[OAuth#OAuth 2.0|OAUTHBEARER]]}} {{defn|[[OAuth#OAuth 2.0|OAuth 2.0]] bearer tokens (RFC 6750), communicated through TLS<ref name=rfc7628>{{cite IETF |title= A Set of Simple Authentication and Security Layer (SASL) Mechanisms for OAuth |rfc= 7628 |date=August 2015 |publisher= [[Internet Engineering Task Force|IETF]] |accessdate= October 7, 2016}}</ref>}}
{{term|[[OAuth|OAUTH10A]]}} {{defn|[[OAuth]] 1.0a message-authentication-code tokens (RFC 5849, Section 3.4.2)<ref name=rfc7628 />}}
{{term|[[OAuth|OAUTH10A]]}} {{defn|[[OAuth]] 1.0a message-authentication-code tokens (RFC 5849, Section 3.4.2)<ref name=rfc7628 />}}

Latest revision as of 23:11, 18 June 2025

Template:Short description Simple Authentication and Security Layer (SASL) is a framework for authentication and data security in Internet protocols. It decouples authentication mechanisms from application protocols, in theory allowing any authentication mechanism supported by SASL to be used in any application protocol that uses SASL. Authentication mechanisms can also support proxy authorization, a facility allowing one user to assume the identity of another. They can also provide a data security layer offering data integrity and data confidentiality services. DIGEST-MD5 provides an example of mechanisms which can provide a data-security layer. Application protocols that support SASL typically also support Transport Layer Security (TLS) to complement the services offered by SASL.

John Gardiner Myers wrote the original SASL specification (RFC 2222) in 1997. In 2006, that document was replaced by RFC 4422 authored by Alexey Melnikov and Kurt D. Zeilenga. SASL, as defined by RFC 4422 is an IETF Standard Track protocol and is, as of 2006Script error: No such module "Check for unknown parameters"., a Proposed Standard.

SASL mechanisms

A SASL mechanism implements a series of challenges and responses. Defined SASL mechanisms[1] include: <templatestyles src="Glossary/styles.css" />

<dt id="Script error: No such module "delink"." >EXTERNAL Template:Defn <dt id="Script error: No such module "delink"." >ANONYMOUS Template:Defn <dt id="Script error: No such module "delink"." >PLAIN Template:Defn <dt id="Script error: No such module "delink"." >OTP Template:Defn <dt id="Script error: No such module "delink"." >SKEY Template:Defn <dt id="Script error: No such module "delink"." >CRAM-MD5 Template:Defn <dt id="Script error: No such module "delink"." >DIGEST-MD5 Template:Defn <dt id="Script error: No such module "delink"." >SCRAM Template:Defn <dt id="Script error: No such module "delink"." >NTLM Template:Defn <dt id="Script error: No such module "delink"." >GS2- Template:Defn <dt id="Script error: No such module "delink"." >GSSAPI Template:Defn <dt id="Script error: No such module "delink"." >BROWSERID-AES128 Template:Defn <dt id="Script error: No such module "delink"." >EAP-AES128 Template:Defn <dt id="Script error: No such module "delink"." >MSN Chat GateKeeper (& GateKeeperPassport) Template:Defn <dt id="Script error: No such module "delink"." >OAUTHBEARER Template:Defn <dt id="Script error: No such module "delink"." >OAUTH10A Template:Defn

SASL-aware application protocols

Application protocols define their representation of SASL exchanges with a profile. A protocol has a service name such as "ldap" in a registry shared with GSSAPI and Kerberos.[2]

As of 2012Script error: No such module "Check for unknown parameters". protocols currently supporting SASL include:

See also

References

<templatestyles src="Reflist/styles.css" />

  1. ↑ Script error: No such module "citation/CS1".
  2. ↑ Script error: No such module "citation/CS1".
  3. ↑ Script error: No such module "citation/CS1".

Script error: No such module "Check for unknown parameters".

External links

Template:Authentication APIs