ISO Development Environment: Difference between revisions
imported>Citation bot Altered template type. Add: journal, date, authors 1-2. | Use this bot. Report bugs. | Suggested by Abductive | Category:Wikipedia articles that are too technical from August 2024 | #UCB_Category 16/49 |
imported>SchlurcherBot m Bot: http → https |
||
| Line 6: | Line 6: | ||
The '''ISODE''' software (pronounced eye-soo-dee-eee), more formally the ''ISO Development Environment'', was an implementation of the [[Open Systems Interconnection|OSI]] [[OSI Model|upper layer protocols]], from transport layer to [[application layer]], which was used in the Internet research community to experiment with implementation and deployment of OSI during the late 1980s and early 1990s. | The '''ISODE''' software (pronounced eye-soo-dee-eee), more formally the ''ISO Development Environment'', was an implementation of the [[Open Systems Interconnection|OSI]] [[OSI Model|upper layer protocols]], from transport layer to [[application layer]], which was used in the Internet research community to experiment with implementation and deployment of OSI during the late 1980s and early 1990s. | ||
The ISODE software was initially a public domain / open source implementation, led by [[Marshall Rose]]. Following version 6.0, Marshall handed the lead over to [[Colin Robbins (software engineer)|Colin Robbins]] and [[Nexor#Personnel and alumni|Julian Onions]], who coordinated the 7.0 and 8.0 releases. Version 8.0 was the final public domain release, made on June 19, 1992. The Open Source version is still available,<ref>{{cite web|url=https://www.ee.ucl.ac.uk/~gpavlou/projects/Emanics/osimis/isode-8.0.5.tar|title=Download Isode 8.0.5 Software}}</ref> even if only for historic interest. The software was ported to a wide set of [[Unix]] and [[Linux]] variants.<ref>{{cite web|title=ISODE Ports|url= | The ISODE software was initially a public domain / open source implementation, led by [[Marshall Rose]]. Following version 6.0, Marshall handed the lead over to [[Colin Robbins (software engineer)|Colin Robbins]] and [[Nexor#Personnel and alumni|Julian Onions]], who coordinated the 7.0 and 8.0 releases. Version 8.0 was the final public domain release, made on June 19, 1992. The Open Source version is still available,<ref>{{cite web|url=https://www.ee.ucl.ac.uk/~gpavlou/projects/Emanics/osimis/isode-8.0.5.tar|title=Download Isode 8.0.5 Software}}</ref> even if only for historic interest. The software was ported to a wide set of [[Unix]] and [[Linux]] variants.<ref>{{cite web|title=ISODE Ports|url=https://ftp.funet.fi/pub/unix/osi/isode-ports.txt|publisher=FUNET|access-date=17 May 2017}}</ref> | ||
== ISODE Stack == | == ISODE Stack == | ||
The ISODE stack<ref>{{cite journal|last=ISODE |author2=Marshall Rose |author2-link=Marshall Rose |author3=Julian Onions |author4=Colin Robbins |author5=Steve Kille|title=The ISO Development Environment: User's Manual (Version 7.0)|year=1992}}</ref> | The ISODE stack<ref>{{cite journal|last=ISODE |author2=Marshall Rose |author2-link=Marshall Rose |author3=Julian Onions |author4=Colin Robbins |author5=Steve Kille|title=The ISO Development Environment: User's Manual (Version 7.0)|year=1992}}</ref> | ||
was an implementation of layers 3 to 6 of the [[OSI reference model|OSI model]]. While the ISODE implementation could be configured to use one of several [[X.25]] (CONS) or connectionless lower layer protocols, many ISODE deployments were based on RFC1006,<ref>{{cite web|title=RFC1006|date=May 1987 |url= | was an implementation of layers 3 to 6 of the [[OSI reference model|OSI model]]. While the ISODE implementation could be configured to use one of several [[X.25]] (CONS) or connectionless lower layer protocols, many ISODE deployments were based on RFC1006,<ref>{{cite web|title=RFC1006|date=May 1987 |url=https://tools.ietf.org/html/rfc1006|publisher=IETF}}</ref> the implementation of OSI transport protocol TP0 as a layer atop [[Transmission Control Protocol|TCP]], in order to use IP-based networks which were becoming increasingly common. | ||
The stack also implemented an [[Abstract Syntax Notation One|ASN.1]] compiler. | The stack also implemented an [[Abstract Syntax Notation One|ASN.1]] compiler. | ||
| Line 17: | Line 17: | ||
=== PP === | === PP === | ||
ISODE formed the basis an implementation for the [[X.400]] email protocol, called PP.<ref>{{cite journal|title=The PP Manual| journal=University College and X-Tel Services LTD., London | date=1991 |url=https://scholar.google.co.uk/citations?view_op=view_citation&hl=en&user=apGmpycAAAAJ&citation_for_view=apGmpycAAAAJ:LkGwnXOMwfcC | last1=Kille | first1=Steve | last2=Onions | first2=Julian }}</ref><ref group=Footnote>PP does not stand for anything. It was a project joke that it did not stand for "[[Postman Pat]]", while "Postman Pat" is a good description of the software, it would have created copyright issues to have used this name.</ref> PP included a fully operational [[SMTP]]/[[MIME]] email server and an X.400/SMTP Mixer<ref>{{cite web|title=RFC 2156|date=January 1998 |url= | ISODE formed the basis an implementation for the [[X.400]] email protocol, called PP.<ref>{{cite journal|title=The PP Manual| journal=University College and X-Tel Services LTD., London | date=1991 |url=https://scholar.google.co.uk/citations?view_op=view_citation&hl=en&user=apGmpycAAAAJ&citation_for_view=apGmpycAAAAJ:LkGwnXOMwfcC | last1=Kille | first1=Steve | last2=Onions | first2=Julian }}</ref><ref group=Footnote>PP does not stand for anything. It was a project joke that it did not stand for "[[Postman Pat]]", while "Postman Pat" is a good description of the software, it would have created copyright issues to have used this name.</ref> PP included a fully operational [[SMTP]]/[[MIME]] email server and an X.400/SMTP Mixer<ref>{{cite web|title=RFC 2156|date=January 1998 |url=https://datatracker.ietf.org/doc/rfc2156/|publisher=IETF|access-date=22 December 2012 |last1=Kille |first1=Steve }}</ref> gateway. | ||
PP also implemented a P7 Messagestore (PPMS). | PP also implemented a P7 Messagestore (PPMS). | ||
| Line 28: | Line 28: | ||
=== FTAM === | === FTAM === | ||
ISODE contained and implementation of [[FTAM]], and implemented an [[FTAM]]-[[FTP]]<ref>{{cite web|title=RFC 1415|date=January 1993 |url= | ISODE contained and implementation of [[FTAM]], and implemented an [[FTAM]]-[[FTP]]<ref>{{cite web|title=RFC 1415|date=January 1993 |url=https://datatracker.ietf.org/doc/rfc1415/|publisher=IETF|access-date=22 December 2012 |last1=Mindel |first1=Joshua L. |last2=Slaski |first2=Robert }}</ref> gateway. | ||
=== VT === | === VT === | ||
| Line 38: | Line 38: | ||
=== OSIMIS === | === OSIMIS === | ||
ISODE has a full implementation of a [[Common Management Information Protocol|CMIP]]/[[Telecommunications Management Network|TMN]] built on top of it by the OSIMIS<ref>{{cite web|title=OSIMIS - OSI Management Information Service|url= | ISODE has a full implementation of a [[Common Management Information Protocol|CMIP]]/[[Telecommunications Management Network|TMN]] built on top of it by the OSIMIS<ref>{{cite web|title=OSIMIS - OSI Management Information Service|url=https://www.ee.ucl.ac.uk/~gpavlou/projects/Emanics/osimis/|publisher=[[University College London|UCL]]|access-date=24 December 2012}}</ref> project. | ||
== Contributors == | == Contributors == | ||
Latest revision as of 12:21, 22 November 2025
Script error: No such module "Unsubst". The ISODE software (pronounced eye-soo-dee-eee), more formally the ISO Development Environment, was an implementation of the OSI upper layer protocols, from transport layer to application layer, which was used in the Internet research community to experiment with implementation and deployment of OSI during the late 1980s and early 1990s.
The ISODE software was initially a public domain / open source implementation, led by Marshall Rose. Following version 6.0, Marshall handed the lead over to Colin Robbins and Julian Onions, who coordinated the 7.0 and 8.0 releases. Version 8.0 was the final public domain release, made on June 19, 1992. The Open Source version is still available,[1] even if only for historic interest. The software was ported to a wide set of Unix and Linux variants.[2]
ISODE Stack
The ISODE stack[3] was an implementation of layers 3 to 6 of the OSI model. While the ISODE implementation could be configured to use one of several X.25 (CONS) or connectionless lower layer protocols, many ISODE deployments were based on RFC1006,[4] the implementation of OSI transport protocol TP0 as a layer atop TCP, in order to use IP-based networks which were becoming increasingly common. The stack also implemented an ASN.1 compiler.
Applications
The ISODE Stack was the basis for a number of OSI applications.
PP
ISODE formed the basis an implementation for the X.400 email protocol, called PP.[5][Footnote 1] PP included a fully operational SMTP/MIME email server and an X.400/SMTP Mixer[6] gateway. PP also implemented a P7 Messagestore (PPMS).
PP was designed by Steve Kille and the lead engineer was Julian Onions.
Quipu
ISODE had a full X.500 and LDAP directory called QUIPU[7] (incorrectly pronounced kwip-ooo by the project). Quipu implemented a DSA and a Directory User Agent (DUA) called DISH. X.500 was considered too heavyweight to access directories, Colin Robbins implemented a proprietary protocol to solve the problem, this was then significantly re-worked by Tim Howes for DIXIE which led to the development of the Lightweight Directory Access Protocol.
QUIPU was designed by Kille and the lead engineer was Robbins, largely funded by the INCA project,[8] and used extensively in the Paradise academic X.500 directory pilot.
FTAM
ISODE contained and implementation of FTAM, and implemented an FTAM-FTP[9] gateway.
VT
ISODE contained a virtual terminal (VT)[10] implementation and a VT-Telnet gateway.
OSISEC
ISODE has a full implementation of a PKI Certificate Authority built on top of it by the OSISEC[11][12] project. OSISEC was developed by Mike Roe & Peter Williams and integrated into ISODE by Robbins.
OSIMIS
ISODE has a full implementation of a CMIP/TMN built on top of it by the OSIMIS[13] project.
Contributors
The following people or groups were listed in the ISODE 8.0 manual[14] as the significant contributors
- The MITRE Corporation
- The Northrop Corporation
- NYSERNet, Inc.
- Performance Systems International, Inc.
- University College London
- The University of Nottingham
- X-Tel Services Ltd (now Nexor)
- The Wollongong Group, Inc.
- Marshall T. Rose
- Colin J. Robbins
- Julian P. Onions
Commercialisation
Several companies used the ISODE software to build successful commercial products and services including (alphabetical order):
- Control Data Corporation used Quipu as the basis of their X.500 product.
- Nexor's email and directory and products are evolutions of PP and Quipu.
- X-Tel Services offered commercial support contracts for the software to the academic community, including JANET and SURFnet.
References
<templatestyles src="Reflist/styles.css" />
- ↑ Script error: No such module "citation/CS1".
- ↑ Script error: No such module "citation/CS1".
- ↑ Script error: No such module "Citation/CS1".
- ↑ Script error: No such module "citation/CS1".
- ↑ Script error: No such module "Citation/CS1".
- ↑ Script error: No such module "citation/CS1".
- ↑ Script error: No such module "Citation/CS1".
- ↑ Script error: No such module "citation/CS1".
- ↑ Script error: No such module "citation/CS1".
- ↑ Script error: No such module "citation/CS1".
- ↑ Script error: No such module "Citation/CS1".
- ↑ Script error: No such module "Citation/CS1".
- ↑ Script error: No such module "citation/CS1".
- ↑ Script error: No such module "citation/CS1".
Script error: No such module "Check for unknown parameters".
Footnotes
<templatestyles src="Reflist/styles.css" />
- ↑ PP does not stand for anything. It was a project joke that it did not stand for "Postman Pat", while "Postman Pat" is a good description of the software, it would have created copyright issues to have used this name.
Script error: No such module "Check for unknown parameters".